Technical Support

Minimum Requirements

Javascript:
Cookies:
Popup Blocker:
Screen Resolution:
Flash Player:
Acrobat Reader: Acrobat Reader 9 (or newer) is required in order to use Seating Arrangement.
If you don't have it installed, you can get it for free at http://get.adobe.com/reader/

Contact Support

The best way to contact our support team is via the Support Forum where you can post your questions and see messages by other users.